Openkore.com

OpenKore Forums
It is currently 19 Nov 2019, 01:42

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Compile Problem under Linux (CentOS 6.0)
PostPosted: 09 Mar 2012, 12:08 
Offline
Noob
Noob

Joined: 09 Mar 2012, 11:50
Posts: 1
Hi! I am posting this message as I have a problem in compiling my Openkore bot to run under CentOS. I followed all the instructions on http://www.openkore.com/index.php/How_to_run_OpenKore so I'm fairly sure I already have all the dependencies needed. I am still, however, getting the following compiling problem whenever i try to run the bot:

make: Entering directory `/home/Bots/Jeth1'
scons: Reading SConscript files ...
Checking Perl configuration ...(cached) yes
Checking for C library ncurses... (cached) yes
Checking for GNU readline 4.3 or higher...(cached) yes
Checking for libcurl...(cached) libcurl 7.19.7
scons: done reading SConscript files.
scons: Building targets ...
buildXS(["src/auto/XSTools/PaddedPackets/PaddedPackets.xs.cpp"], ["src/auto/XSTools/PaddedPackets/PaddedPackets.xs"])
Creating src/auto/XSTools/PaddedPackets/PaddedPackets.xs.cpp ...
Null filename used at -e line 13.
scons: *** [src/auto/XSTools/PaddedPackets/PaddedPackets.xs.cpp] Error 25
scons: building terminated because of errors.
Compilation failed. Please read http://www.openkore.com/index.php/How_to_run_OpenKore for help.
make: Leaving directory `/home/Bots/Jeth1'
Can't locate loadable object for module XSTools in @INC (@INC contains: /home/Bots/Jeth1/src/deps /home/Bots/Jeth1/src /home/Bots/Jeth1 /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at ./openkore.pl line 25

This is actually not my first time to run an Openkore bot on Linux as I have successfully ran previous bots on other Linux distro before but this is the first time that i encountered this kind of error. I have searched the forums and consequently the web for a similar problem or a possible solution but to no avail. I am therefore hoping that someone can help me out on this.

The Linux distro that I am currently using is a freshly installed copy of CentOS 6.0. If you need additional info, please let me know.

Thanks!


Top
 Profile  
 
 Post subject: Re: Compile Problem under Linux (CentOS 6.0)
PostPosted: 11 Mar 2012, 03:14 
Offline
Spam Generator
Spam Generator

Joined: 04 Apr 2008, 09:30
Posts: 501
Location: Melbourne, City of beer and awful sushis
Referred thread to devs. Be patient.

_________________
Make Openkore Awesome. Join the team.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group