Openkore.com
http://forums.openkore.com/

Freeze 20sec after map change(teleport, relog, map change)
http://forums.openkore.com/viewtopic.php?f=10&t=212549
Page 1 of 1

Author:  zeroone [ 22 Jan 2018, 21:53 ]
Post subject:  Freeze 20sec after map change(teleport, relog, map change)

Hi guys

my bot freezes '20sec' after map changes( after using teleport, after relog, after going to another map..)

So I changed 'ai' in timeouts.txt but it doesn't work

I think AI is not a reason because after teleport my bot immediately become a 'route state' or 'attack state' but only freeze.
I also changed botting type from 'automatic botting' to 'manual botting' and did anything. However my bot never response in 'the freezing time'
In the freezing time, kore is working but only my character is fixed


here's my timeout.txt
-------------------------------------------------------------------------
# Activate AI after x seconds after the map's loaded
ai 0.5

ai_teleport 0.1
ai_teleport_away 0.1
ai_teleport_idle 0.5
ai_teleport_portal 0.1
ai_teleport_hp 0.1
ai_teleport_safe_force 120

ai_teleport_retry 0.5
ai_teleport_delay 0.5

ai_portal_wait 0.5
-----------------------------------------------------------------

Is there any other configs to change for this problems?

Author:  fadreus [ 23 Jan 2018, 04:06 ]
Post subject:  Re: Freeze 20sec after map change(teleport, relog, map change)

zeroone wrote:
# Activate AI after x seconds after the map's loaded
ai 0.5

ai_teleport 0.1
ai_teleport_away 0.1
ai_teleport_idle 0.5
ai_teleport_portal 0.1
ai_teleport_hp 0.1
ai_teleport_safe_force 120

ai_teleport_retry 0.5
ai_teleport_delay 0.5

ai_portal_wait 0.5


How about using this settings?
Code:
ai 2

ai_teleport 1
ai_teleport_away 3
ai_teleport_idle 4
ai_teleport_portal 2
ai_teleport_hp 3
ai_teleport_safe_force 120

ai_teleport_retry 0.5
ai_teleport_delay 0.5

Author:  zeroone [ 23 Jan 2018, 04:36 ]
Post subject:  Re: Freeze 20sec after map change(teleport, relog, map change)

Thank you fadreus.

I changed timeouts.txt that you suggested but it doesn't work.

I think it's not a timeouts.txt problems.

After map changing(relog, teleport, move next map) , I can see my bot is there(through real RO client screen) but actually it seems that bot doesn't exist.
I cannot deal with my bot( game message says that character already deal with another character) and aggressive monsters doesn't recognize bot until bot unfreeze.

Author:  fadreus [ 23 Jan 2018, 17:20 ]
Post subject:  Re: Freeze 20sec after map change(teleport, relog, map change)

zeroone wrote:
After map changing(relog, teleport, move next map) , I can see my bot is there(through real RO client screen) but actually it seems that bot doesn't exist.
I cannot deal with my bot( game message says that character already deal with another character) and aggressive monsters doesn't recognize bot until bot unfreeze.


This is weird.
Let me guess, private server?

Author:  zeroone [ 23 Jan 2018, 21:10 ]
Post subject:  Re: Freeze 20sec after map change(teleport, relog, map change)

no, I play kRO zero server.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/