Openkore.com

OpenKore Forums
It is currently 13 Dec 2018, 19:16

All times are UTC - 5 hours [ DST ]



Forum rules


This server is currently not maintained and tables folder (including connection info) is outdated. Read the wiki for instructions on how to update those information. Please contribute your updated info. Contact Cozzie to join the team as a regular server supporter.



Post new topic Reply to topic  [ 72 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7, 8  Next
Author Message
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 12 Jul 2017, 03:45 
Offline
Noob
Noob

Joined: 04 Jul 2008, 10:39
Posts: 11
finished reading through this thread, finished installing a compatible perl that works with openkore.

I am one of the old timer devs who wrote many of the route functions back in 2003~2005. But there are tons of changes I noticed. Lets see if I am still up to this.


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 12 Jul 2017, 15:30 
Offline
Noob
Noob

Joined: 05 Jul 2017, 21:56
Posts: 12
Hi guys! I have cleaned the thread and left all the useful information here. Just to remind you guys again this is not a support topic!

If you expect to find a download link / zip here, Then you are in the wrong place.

This is solely for developer discussion about XKore1 packet structure and how to tackle it (in the code) in-order to support new pRO servers (Loki, Thor) botting using XKore 1.

Then once that is solved, then Heroo and the others will probably setup another topic for a download or merge necessary code changes to the git repository and probably post another topic to handle encryption and XKore 0.

Any user that will post support questions (how to make this work? where to download? how about kore 0)? will probably get cleaned and will be warned.

hopefully we can figure this out very soon!
Thank you very much


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 13 Jul 2017, 06:06 
Offline
Noob
Noob

Joined: 10 Jul 2017, 11:02
Posts: 15
dawnvillain wrote:
fclose wrote:
fixed unknown token problem.

tested with xkore 0. can enter map and read all stats. but still can't do anything.
major change is in MessageTokenizer that wrap to the packet segmentation. I think it should work with x1 but I can't try myself.



xkore 0 works... (sort of ?)

Testing fclose files.

Scenario:

I dual logged-in my Acolyte and Swordsman on the same map.
Then, i placed them side by side.

Image

Then I logged out the Swordsman
Then I turn on bot for Swordsman
It is able to login... kinda?
even Openkore is saying that "You are now in the game."
However, my Swordsman is nowhere to be found in game!
When I checked the "Party Status Window", it is saying that my Swordsman is "Online".

Image

then after a few minutes... the bot disconnects.

Image

PS: I used fclose's pRO.pm & recvpackets


How were you able to bypass the issue with the map login? I'm stuck on that it gets timeout.


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 13 Jul 2017, 07:23 
Offline
OpenKore Monk
OpenKore Monk

Joined: 04 Apr 2008, 10:10
Posts: 474
jsteng wrote:
finished reading through this thread, finished installing a compatible perl that works with openkore.

I am one of the old timer devs who wrote many of the route functions back in 2003~2005. But there are tons of changes I noticed. Lets see if I am still up to this.

In case you're interested, some people are trying to improve on your routing code :) viewtopic.php?f=36&t=1350&start=30

_________________
Got your topic trashed by a mod?

Trashing topics is one click, and moving a topic to its proper forum is a lot harder. You expend the least effort in deciding where to post, mods expend the least effort by trashing.

Have a nice day.


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 13 Jul 2017, 21:26 
Offline
Noob
Noob

Joined: 13 Jul 2017, 20:38
Posts: 1
these are my observations with wireshark. maybe it can help
red = send, blue = received
##roclient##

0A76 master_login /80


01B5 account_payment_info
0276 account_server_info /115


0275 game_login /37


fa17 ?
082D received_characters_info


09A1 sync_received_characters /2
09A1 sync_received_characters /2


099D received_characters /436
099D received_characters /304


0187 sync /6


0187 sync /6


08b8 send_pin_password /10


08b9 login_pin_code_request /12


0066 char_login /3


0071 received_character_ID_and_Map /28


0436 map_login /19


0009 ? /9
0010 ? /149
000b ? /28
000b ? /113


0005 guild_check /5 #encrypted?
0009 guild_info_request /46 #encrypted?


002f ? /482
000b ? /57
002f ? /482
000b ? /57
0009 ? /9
0029 ? /29


0187 sync /6 (char select)
0011 sync /17 (ingame)

it looks like encryption starts after map_login.


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 14 Jul 2017, 00:14 
Offline
Noob
Noob

Joined: 10 Jul 2017, 11:02
Posts: 15
materpogi01 wrote:
these are my observations with wireshark. maybe it can help
red = send, blue = received
##roclient##

0A76 master_login /80


01B5 account_payment_info
0276 account_server_info /115


0275 game_login /37


fa17 ?
082D received_characters_info


09A1 sync_received_characters /2
09A1 sync_received_characters /2


099D received_characters /436
099D received_characters /304


0187 sync /6


0187 sync /6


08b8 send_pin_password /10


08b9 login_pin_code_request /12


0066 char_login /3


0071 received_character_ID_and_Map /28


0436 map_login /19


0009 ? /9
0010 ? /149
000b ? /28
000b ? /113


0005 guild_check /5 #encrypted?
0009 guild_info_request /46 #encrypted?


002f ? /482
000b ? /57
002f ? /482
000b ? /57
0009 ? /9
0029 ? /29


0187 sync /6 (char select)
0011 sync /17 (ingame)

it looks like encryption starts after map_login.

Do you know where packet 059A is used? I'm getting errors on that one.


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 20 Jul 2017, 16:33 
Offline
Noob
Noob

Joined: 20 Jul 2017, 16:27
Posts: 6
LINK REMOVED FOR SPAMMING IN 3 THREADS with the same link

- Mercurial


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 21 Jul 2017, 03:31 
Offline
Noob
Noob

Joined: 14 Jul 2017, 00:16
Posts: 3
materpogi01 wrote:
these are my observations with wireshark. maybe it can help
red = send, blue = received
##roclient##

0A76 master_login /80


01B5 account_payment_info
0276 account_server_info /115


0275 game_login /37


fa17 ?
082D received_characters_info


09A1 sync_received_characters /2
09A1 sync_received_characters /2


099D received_characters /436
099D received_characters /304


0187 sync /6


0187 sync /6


08b8 send_pin_password /10


08b9 login_pin_code_request /12


0066 char_login /3


0071 received_character_ID_and_Map /28


0436 map_login /19


0009 ? /9
0010 ? /149
000b ? /28
000b ? /113


0005 guild_check /5 #encrypted?
0009 guild_info_request /46 #encrypted?


002f ? /482
000b ? /57
002f ? /482
000b ? /57
0009 ? /9
0029 ? /29


0187 sync /6 (char select)
0011 sync /17 (ingame)

it looks like encryption starts after map_login.



sir ung character_move at attack nakuha mo rin ba ung packet?


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 23 Jul 2017, 21:45 
Offline
Noob
Noob

Joined: 23 Jul 2017, 21:33
Posts: 1
Hello!

Just noticed that ragnarok ph modifies a process called csrss.exe. I had tested it on 4 computers with windows 7 and the results are the same.

All computers with ragnarok ph installed have their csrss.exe without username and description in the task manager. (see picture)
Image

Maybe this is the reason why packet editing software can't hook to the ragnarok ph client?

Is my observation the same with you guys?

For your reference:
https://en.wikipedia.org/wiki/Client/Se ... _Subsystem


Top
 Profile  
 
 Post subject: Re: Packet Tokenizer issue with users of XKore 1
PostPosted: 23 Jul 2017, 23:37 
Offline
Noob
Noob

Joined: 04 Jul 2017, 22:55
Posts: 18
iwanttobot wrote:
Hello!

Just noticed that ragnarok ph modifies a process called csrss.exe. I had tested it on 4 computers with windows 7 and the results are the same.

All computers with ragnarok ph installed have their csrss.exe without username and description in the task manager. (see picture)
Image

Maybe this is the reason why packet editing software can't hook to the ragnarok ph client?

Is my observation the same with you guys?

For your reference:
https://en.wikipedia.org/wiki/Client/Se ... _Subsystem


Csrss is responsible for console windows, creating and/or deleting threads, and some parts of the 16-bit virtual MS-DOS environment


csrss.exe is native for windows NT. so I don't think this is the reason why packet editing is not working.
this is more of the security measures that the new ragnarok ph provider implements. more like they encrypt their packets or shuffles them.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 72 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7, 8  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group