Openkore.com

OpenKore Forums
It is currently 19 Nov 2018, 04:59

All times are UTC - 5 hours [ DST ]





Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 
Author Message
 Post subject: Poem of bragi spammed packets
PostPosted: 21 Aug 2013, 23:01 
Offline
Human
Human

Joined: 05 Oct 2010, 09:46
Posts: 24
Problem

openkore lags when a bard uses Poem of bragi and moves around. It causes the network::received.pm to keep on receiving 08C7. When the skills ends, it'll spam 0120.

This would makes the nearby openkore unresponsive due to the burst of 08C7 packets. Worst case, it DC'ed them

Help

My first tips given by EternalHarvest was to look into handlers. and with much searching, i found out that if i could suppress the received packet (making it blind to it). openkore will not lags (not sure is correct or not).

so i poke around inserting

Code:
if ($args->{switch} eq '08C7') {
  undef $args->{switch};
}


in these three .pm (in src/Network)
PacketPraser.pm
iRO.pm
Received.pm

somehow it did manage to deleted the packets, but it still there. It still received the packets, and openkore still lags.

Since the case is similar to devotion, i've tried to look at the devotion solution. But didn't manage to find anything.

Questions

Is it possible to delete/remove the $handlers related to the nerwork::received ?
How can i handle these kind of packets? Where should i start?
Is it possible to ignore/blind the received packets?
Is there any work around?


Top
 Profile  
 
 Post subject: Re: Poem of bragi spammed packets
PostPosted: 22 Aug 2013, 06:17 
Offline
Developers
Developers
User avatar

Joined: 30 Apr 2008, 14:17
Posts: 621
Location: Moskow (Russia)
Quote:
'08C7' => ['area_spell', 'x2 a4 a4 v2 C3', [qw(ID sourceID x y type range fail)]], # -1


Write your settings.

_________________
All my posts are made by machine translator!
¤ Manual ¤ Anti BotKiller ¤ Packet Extractor v3 ¤
Image
Image


Top
 Profile  
 
 Post subject: Re: Poem of bragi spammed packets
PostPosted: 22 Aug 2013, 09:20 
Offline
Human
Human

Joined: 05 Oct 2010, 09:46
Posts: 24
Thank you for the reply sir,

Yes, i did notice this in ServerType0.pm where :

Code:
'08C7' => ['area_spell', 'x2 a4 a4 v2 C3', [qw(ID sourceID x y type range fail)]]


but not sure by just adding to iRO.pm/mRO.pm would solve the problem. How does it exactly works?
Does it just store/define the 08C7 for later storing?

Why does kore lags when it encounter such things? Does it stuck in Buffer? I've tried debug 1, but it was too much and too fast and i didn't know what to look at.

Anyhow, the problem is solved. I updated to r8662. Previously was r8339 as i read some of the forums suggested (in mRO Official Forums)

The problem regarding that was because of the mRO.pm in both Send/Received in the src/Network have some problem that causes the kore to disconnected after entering the game.

The solution was provided here : http://forums.openkore.com/viewtopic.php?p=75730#p75730

I'll quote it here :

Quote:
Are you using the latest version of openkore? if yes, you need to edit the src\Network\Send\mRO.pm and then add this code

Code:
sync 0360
character_move 035F
actor_info_request 0368
actor_look_at 0361
item_take 0362
item_drop 0363
storage_item_add 0364
storage_item_remove 0365
skill_use_location 0366
party_setting 07D7


after the

Code:
buy_bulk_vender 0801




Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group