Openkore.com
http://forums.openkore.com/

Issue with some skill status not detected while still active
http://forums.openkore.com/viewtopic.php?f=56&t=30585
Page 1 of 1

Author:  Dark Airnel [ 19 Mar 2013, 00:27 ]
Post subject:  Issue with some skill status not detected while still active

I dunno if this is a known issue or a bug but when I set my bot to cast Reject Sword Lv 5 which is suppose to last until it is triggered 3x by a monster hit, Kore only detects it for a while or a few seconds after it was cast and then will detect that the character no longer has the status:

Code:
s
----------------------- Status -------------------------
XXXXXXXXXXX                      HP:  69425/69425 (100%)
Shadow Chaser Boy                SP:     1142/1273 (89%)
Base: 160
Job : 50
Zeny: 66,103,453             Weight:   2797/5030 (55.6%)
Statuses: Increase Agility, Berserk Potion, Preserve, Blessing, Impositio
Manus, Hwergelmir's Tonic
Spirits/Coins/Amulets: 0
--------------------------------------------------------
Total Damage:              0 Dmg/sec: 0.00
Total Time spent (sec):      0.00
Last Monster took (sec):     0.00
--------------------------------------------------------
ss 390 5
You are now: Action Delay (Duration: 0.147s)
You are now: Reject Sword (Duration: 9.999s)
You use Reject Sword on yourself (Lv: 5)
You are no longer: Action Delay
You are no longer: Reject Sword
s
----------------------- Status -------------------------
XXXXXXXXXXX                      HP:  69425/69425 (100%)
Shadow Chaser Boy                SP:     1112/1273 (87%)
Base: 160
Job : 50
Zeny: 66,103,453             Weight:   2797/5030 (55.6%)
Statuses: Increase Agility, Berserk Potion, Preserve, Blessing, Impositio
Manus, Hwergelmir's Tonic
Spirits/Coins/Amulets: 0
--------------------------------------------------------
Total Damage:              0 Dmg/sec: 0.00
Total Time spent (sec):      0.00
Last Monster took (sec):     0.00
--------------------------------------------------------


That whole sequence happened in approximately 11 seconds. When in Xkore 1 mode, the status icon for Reject Sword is still active but Kore does not detect it to be active anymore. As a result, if the config block is set to cast Reject Sword if it is no longer active, Kore will cast it approximately every 10 seconds even when the skill is still active. If you use timeout, the skill might have been triggered already and Kore will not cast it again if it was triggered before the timeout is due.

Author:  Kaspy [ 19 Mar 2013, 03:13 ]
Post subject:  Re: Issue with some skill status not detected while still active

This is a bug, Kore can only recognize the end of buff's when the timeout.

For example, Mystical Amplification also has a problem like this.

Author:  Dark Airnel [ 05 Apr 2013, 01:23 ]
Post subject:  Re: Issue with some skill status not detected while still active

Does that mean we will not be getting a resolution for this for quite some time? :(

Author:  Kaspy [ 05 Apr 2013, 15:16 ]
Post subject:  Re: Issue with some skill status not detected while still active

Dark Airnel wrote:
Does that mean we will not be getting a resolution for this for quite some time? :(

It depends on the goodwill of developers and other users who want to help the project

Author:  Dark Airnel [ 05 Apr 2013, 15:53 ]
Post subject:  Re: Issue with some skill status not detected while still active

I'm sorry. Maybe what I am really trying to ask is if this is something that should be adjusted server-side or something to be improved on Kore.

Author:  Kaspy [ 05 Apr 2013, 16:31 ]
Post subject:  Re: Issue with some skill status not detected while still active

Dark Airnel wrote:
should be adjusted server-side or something to be improved on Kore.

I believe it is the client side, because, so remember, the server does not send any package warning that the buff is over. You can check using a sniff or seeing the source of an open source emulator (rAthena, brAthena, for example).

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/