Openkore.com

OpenKore Forums
It is currently 18 Sep 2019, 14:02

All times are UTC - 5 hours [ DST ]





Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: got an error when i run wxstart..
PostPosted: 19 Jun 2011, 10:10 
Offline
Noob
Noob

Joined: 25 May 2011, 05:30
Posts: 8
OpenKore version what-will-become-2.1
SVN revision: 7734
No loaded plugins.

Error message:
Cannot load interface Interface::Wx. Error:
ERROR.TXT :

Global symbol "%field" requires explicit package name at src/Interface/Wx.pm line 285.
Global symbol "%field" requires explicit package name at src/Interface/Wx.pm line 285.
Compilation failed in require at (eval 236) line 1.
BEGIN failed--compilation aborted at (eval 236) line 1.

Stack trace:
Trace begun at src\Interface.pm line 51
Interface::loadInterface('Interface', 'Wx') called at openkore.pl line 44
main::__start at start.pl line 136

Died at this line:
eval "use $module;";
* if ($@) {
ModuleLoadException->throw(error => "Cannot load interface $module. Error:\n$@",


pLS HELP DONT KNOW WHAT THIS MEANS..


Top
 Profile  
 
 Post subject: Re: got an error when i run wxstart..
PostPosted: 19 Jun 2011, 10:50 
Offline
Developers
Developers

Joined: 05 Dec 2008, 05:42
Posts: 1811
Looks like you have modified Wx.pm (nothing like that at line 285 in r7734). %field deprecation explained in the wiki in "porting plugins".


Top
 Profile  
 
 Post subject: Re: got an error when i run wxstart..
PostPosted: 19 Jun 2011, 12:48 
Offline
Noob
Noob

Joined: 25 May 2011, 05:30
Posts: 8
i didnt modify anything, coz i dont know how..

i was trying to change my wx look from
viewtopic.php?f=34&t=7629&hilit=wx+interface

i followed the instructions and thats what i got.. weird..
i just tried doing it coz i think it look much better than a plain wx and more options..

pls help..


Top
 Profile  
 
 Post subject: Re: got an error when i run wxstart..
PostPosted: 19 Jun 2011, 12:57 
Offline
Noob
Noob

Joined: 25 May 2011, 05:30
Posts: 8
btw, i'm using the openkore ready from collectskin on this site and when i replace the wx.pm which is a larger file as i check by replacing it from

viewtopic.php?f=34&t=7629&hilit=wx+interface

i got an error.


Top
 Profile  
 
 Post subject: Re: got an error when i run wxstart..
PostPosted: 20 Jun 2011, 04:37 
Offline
Administrator
Administrator
User avatar

Joined: 24 Apr 2008, 12:02
Posts: 1301
There was a warning "Use the Wx interface provided by the SVN. I Click doesn't update this version anymore."
So As a Result. WX Mod is no more compatible with SVN version.

Bug Solved.

_________________
Join our Team. Click here.
Image


Image


Top
 Profile  
 
 Post subject: Re: got an error when i run wxstart..
PostPosted: 20 Jun 2011, 14:52 
Offline
Noob
Noob

Joined: 25 May 2011, 05:30
Posts: 8
@klabmouse -- is there a way that we can apply that wx v24 that has more option ang looks better.. coz it would really help alot since even emoticons is there.. pls help..


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group