Openkore.com
http://forums.openkore.com/

endless autostorage loop
http://forums.openkore.com/viewtopic.php?f=7&t=212130
Page 1 of 1

Author:  troypogs777 [ 23 Jul 2017, 04:25 ]
Post subject:  endless autostorage loop

my bot on Re:Start keeps on autostoraging. It seems that it can't detect the items present in the inventory though it can fetch them from the storage. I've posted this problem endlessly but to no solution and can't even find one in the forums or git.
See what the bot does, is go autostorage, fetches the item then goes to the lockmap after it arrives at the lockmap, it goes to autostorage again because it thinks it has no awakening potions and silver arrow quivers and the process goes on and on. It been like this for weeks and I can't level because of this fucking problem.

item_control.txt
Code:
##### HEAL/SUPPORT ITEMS #####
# Adjust these to your needs

Butterfly Wing 5 0 0
Fly Wing 100 1 0

Blue Potion 0 1 0
Condensed Red Potion 50 1 0
Condensed White Potion 50 1 0
Condensed Yellow Potion 50 1 0
Green Potion 0 1 0
Red Potion 25 1 0
Orange Potion 25 1 0
White Potion 25 1 0
Yellow potion 25 1 0

Silver Arrow Quiver 5 0 0
##### ARROWS #####
# You may want to modify these if you're an archer/hunter

Silver Arrow 500 0 0


autostorage lines
Code:
getAuto Awakening Potion {
   minAmount 1
   maxAmount 5
   passive 0
}
getAuto Silver Arrow Quiver {
   minAmount 1
   maxAmount 5
   passive 0
}
getAuto Butterfly Wing {
   minAmount 1
   maxAmount 5
   passive 0
}


Console sreenshot
Image

Author:  troypogs777 [ 25 Jul 2017, 19:58 ]
Post subject:  Re: endless autostorage loop

anyone? no one can help? :cry:

Author:  SkylorD [ 25 Jul 2017, 20:02 ]
Post subject:  Re: endless autostorage loop

Read :

http://openkore.com/index.php/Items_control.txt

Author:  troypogs777 [ 25 Jul 2017, 20:13 ]
Post subject:  Re: endless autostorage loop

SkylorD wrote:


My other bots are fine. But my hunter just seems to keep on autostoraging. If you ask about reading I have spent hours and testing changing my items control to match the config autostorage but to no avail. It seems the bot can't detect that he has the items in the inventory. The other bots they work fine. they have the same item to autostorage except the quiver. IDK if the quiver is the thing that makes it wrong. Please help, its given me such a headache I might throw my laptop in a fit of rage.

Author:  hakore [ 26 Jul 2017, 00:16 ]
Post subject:  Re: endless autostorage loop

Try increasing timeout for "ai" so it won't kick in before the server send you the inventory packets after a map load.

See timeouts.txt.

Author:  troypogs777 [ 26 Jul 2017, 06:43 ]
Post subject:  Re: endless autostorage loop

hakore wrote:
Try increasing timeout for "ai" so it won't kick in before the server send you the inventory packets after a map load.

See timeouts.txt.

thanks. i'll try that bec. that's the only plausible solution due to the server being so laggy. @_@

Author:  rentard [ 27 Jul 2017, 07:32 ]
Post subject:  Re: endless autostorage loop

You need an older bot version. Someone screwed it up hard.

Author:  ladyG [ 28 Jul 2017, 12:48 ]
Post subject:  Re: endless autostorage loop

Does your bot work? My can not connect can you help me? Maybe the problem of changing ip ... thanks in advance

Author:  troypogs777 [ 29 Jul 2017, 06:14 ]
Post subject:  Re: endless autostorage loop

so this problem is solved. Apparently, the timeouts.txt was causing the problem as the ai was loaded immediately after connecting from the map server. Giving a delay before the ai is loaded makes the items load and the bot detect them. I completely overlooked my timeouts. thanks please close the topic. SOLVED!

Author:  kali [ 29 Jul 2017, 07:27 ]
Post subject:  Re: endless autostorage loop

troypogs777 wrote:
so this problem is solved. Apparently, the timeouts.txt was causing the problem as the ai was loaded immediately after connecting from the map server. Giving a delay before the ai is loaded makes the items load and the bot detect them. I completely overlooked my timeouts. thanks please close the topic. SOLVED!

Sounds great!

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/