Plan to walk in lock map !

Other plugins for extending OpenKore's functionality. This forum is only for posting new plugins and commenting on existing plugins. For support, use the Support forum.

Moderator: Moderators

Posts: 214
Joined: 24 Nov 2010, 03:08
Noob?: Yes

Re: Plan to walk in lock map !

#31 Post by sofax222 »

glennlevi wrote:Variable "%field" is not imported at src/AI/ line xxxx.
Global symbol "%field" requires explicit package name at src/AI/ line xxxx.
Please show the lines near the "src/AI/ line xxxx."

Posts: 5
Joined: 29 Jun 2010, 14:27
Noob?: Yes

Re: Plan to walk in lock map !

#32 Post by hatedrox »

i got this error what should i do?

Code: Select all

OpenKore version what-will-become-2.1
SVN revision: 8077
Loaded plugins:
  plugins/macro/ (macro)
  plugins/planLockMapWalk/ (planLockMapWalk)

Error message:
Cannot load control file 

Stack trace:
Trace begun at D:\Copy of kore 7\src\ line 439
Settings::loadByHandle(56) called at D:\Copy of kore 7\plugins\planLockMapWalk\ line 69
planLockMapWalk::on_start3('start3', undef, undef) called at src\ line 433
Plugins::callHook('start3') called at src\ line 288
main::loadDataFiles at src\ line 81
main::mainLoop at src\ line 75
Interface::mainLoop('Interface::Console::Win32=HASH(0x121841c)') called at line 97
main::__start at line 136

Died at this line:
  		$filename = $object->{name} || $object->{internalName} if (!defined $filename);
* 		if ($object->{type} == CONTROL_FILE_TYPE) {

Posts: 4
Joined: 05 Jul 2018, 05:16
Noob?: No

Re: Plan to walk in lock map !

#33 Post by redheadanny »

@ hatedrox

put a blank macro.txt file in your config folder. I believe the creates a temporary macro to keep track of what it is doing. i had the same error using it on a test bot and after adding the macro.txt file to config all is fine.


(1) When starting Kore puase the bot and read what plugins it has loaded in the console window '
If the Plugin is not shown in the list follow the next step, if the plugin is listed move to step 3.

(2) Inside you Control folder open the file called sys.txt and you need to look for this :

###### Plugin settings ######
# loadPlugins <0|1|2|3>
# this option controls loading of plugins at startup or when the "plugin load all" command is used.
# 0 : do not load plugins
# 1 : load all plugins
# 2 : only load plugins that are listed in loadPlugins_list
# 3 : load all plugins except those listed in skipPlugins_list

loadPlugins 2

# loadPlugins_list <list>
# if loadPlugins is set to 2, this comma-separated list of plugin names (filename without the extension)
# specifies which plugin files to load at startup or when the "plugin load all" command is used.

loadPlugins_list macro,profiles,breakTime,planLockMapWalk,wayPoint,raiseStat,raiseSkill,map,reconnect,eventMacro,item_weight_recorder,xconf

Where it say's loadPlugins 2, you can either change it it 3 quick fix but probly not the best fix. OR

Add the plugin Name to the LoadPlugins_list as i had to do above

I am not sure why but you have to do this for every new plugin/.pl file you create or add to the plugins folder.

(3) if your plugin is loading but not working make sure it is in the OpenKore/plugins folder or
OpenKore/Plugins/your own folder .
For Example: openKore/plugins/planLockMapWalk/ is what i do..

Kore will only look 2 folder deep for .pl files so make sure you dont add a 3rd folder for your .pl files

(4) For this Plugin you need a macro.txt and a planwalk.txt file in your control folder.

The macro.txt can be blank / or have other macro's you use as long as it is there.

The planwalk.txt can also be blank but the plugin wont have anything to do.

This is an Example of what you put in your planwalk.txt file:



You have the mapname inside the [ ] , then a list of waypoints x:y . Kore will set the first waypoint
234,26 then once you reach that way point it will move onto the next 123,255.

You can have multiple maps in the file like so:





and so on...

(4) Finaly make sure your lockMap is set to one of the maps in the planwalk file.

The plugin only works for the lockMap set in your config. aslo you will need to add a few lines to your config file.

###### Auto Plan Walk Macro Cofig #####

autoPlanLockMapWalk 1 # This is 1 ON or 0 OFF

planWalk_file planwalk.txt # This directs the plugin to you planwalk.txt file

planWalk_maxRouteTime 600 # This is the max route time ( i set it to 6000 for maps like
# ama_dun01 because it can take some time to get for on side
# to the other being a maze and alot of mob to fight on the way.

Ok , well i hope this helps a few people out . i know i had a hard time getting this plugin to work.
Mainly because of the sys.txt file not loading the plugins i was trying to use..

Post Reply