MoonRo | Unable to read out CryptKeys

Private server support - Only post connectivity issues in the subforum!

Moderator: Moderators

User avatar
Posts: 1
Joined: 22 Mar 2023, 10:52
Noob?: No

MoonRo | Unable to read out CryptKeys

#1 Post by ro-bot »

Hello Everyone, i'm hardly Struggling on reading out the CryptKeys.

I tried everything which i was able to find in the Forums and FAQ.

First i read out the Packets with WPE and got the Master_version and clientversion.
The charBlockSize was also hard to figure out, due to the executable seems to be protected but i was able to get the information with HW32, w32dasm and Peek
but now my main issue is to read out the CryptKeys. already tried to get a working, the first issue was, that the ragexe-file had 2 entry points, so the script i was able to find,
was edited to give me a choice between the entry points (1 or 2) to try to readout the Informations and was shown with Verbose to figure out errors.
but even after 3 days i'm still unable to get the cryptKeys - all results are always the same.
i'm able to connect and select the Character, but as soon the bot tries to connect to the Mapserver, it fails.

Here are all informations i was able to figure out yet, but i would highly appreciate every kind of help on this

port 6900
master_version 16
version 29
serverType kRO_RagexeRE_2018_05_02b
serverEncoding Western
addTableFolders translated/kRO_english;kRO;iRO;eA
recvpackets recvpackets.txt
pauseCharLogin 1
charBlockSize 147
sendCryptKeys 0x00000000, 0x00000000, 0x00000000


Thanks in Advance,