Openkore.com

OpenKore Forums
It is currently 23 Oct 2018, 20:23

All times are UTC - 5 hours [ DST ]





Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 
Author Message
 Post subject: euRO | SVN | Blacksmith repair skill causes disconnect
PostPosted: 14 Sep 2008, 23:24 
Offline
Noob
Noob
User avatar

Joined: 06 Apr 2008, 22:00
Posts: 14
Here is one more problem which I have noticed in Kore since a while. The problem is still present in the current SVN.

This one is regarding the Blacksmith/Whitesmith skill "Repair Weapon" (and also the Kore config option repairAuto).
When using the "Repair Weapon" skill on someone the skill will at first seem to work fine, but using the "repair <equip id>" command causes a disconnect in both console only and XKore mode:

Kore Console wrote:
sp 108 Test_Char
You are casting Weapon Repair on player Test_Char (0) (time 2534ms)
--------Repair List--------
70 Monk Hat
--------------------------- <- fine up till here
repair 70 <- causes disconnect


If the Kore config option "repairAuto" is enabled the disconnect will be caused instantly after using the repair skill.

So far I have only tested this on euRO, since I do not have access to a Blacksmith or broken equip on any other official server :)
I'm assuming it has to do with the padded packets.

Anyone care to look into it?

_________________
ProMVP3 - A Ragnarok MVP Timer and Drop Log


Top
 Profile  
 
 Post subject: Re: euRO | SVN | Blacksmith repair skill causes disconnect
PostPosted: 24 Sep 2008, 11:28 
Offline
Super Moderators
Super Moderators
User avatar

Joined: 06 May 2008, 12:47
Posts: 801
It also occurs on a 8_4 server.
Lets take a look at it.

[EDIT]
Can people to test this on different serverTypes?

_________________
One ST0 to rule them all? One PE viewer to find them!
One ST_kRO to bring them all and in the darkness bind them...

Mount Doom awaits us, fellowship of OpenKore!


Top
 Profile  
 
 Post subject: Re: euRO | SVN | Blacksmith repair skill causes disconnect
PostPosted: 26 Sep 2008, 03:34 
Offline
Moderators
Moderators
User avatar

Joined: 04 Apr 2008, 09:30
Posts: 235
Location: My House
it's confirmed and i would bet on it it affect all of the serverType.

_________________
Image
Follow The template in Asking Question or Be Trashed


Top
 Profile  
 
 Post subject: Re: euRO | SVN | Blacksmith repair skill causes disconnect
PostPosted: 26 Sep 2008, 04:15 
Offline
Super Moderators
Super Moderators
User avatar

Joined: 06 May 2008, 12:47
Posts: 801
i've got a succesfull repair with no DC here, but its time to go to class :P
So i'll test some more later and maybe commit.

[EDIT]
fix for the Blacksmith repair skill (while using repairAuto) causes disconnect is in SVN now!

However the command repair will still cause disconnection.
This is because the of the fact that the packet needs more information
than that the user currently has to insert as a parameter on the repair command.

To make the command work you should change the command:
Code:
repair [index]

to:
Code:
repair [index nameID status status2 listID ]


However its very tiresome for the user having to type in all this information.
Therefor i've come up with some idea's.
IDEA 1:
Since status and status2 seem to be the same for every item (maybe different on different serverTypes),
its possible make them standard for each serverType.

IDEA 2:
caching the repair list and trough the index, the other data will become available.

_________________
One ST0 to rule them all? One PE viewer to find them!
One ST_kRO to bring them all and in the darkness bind them...

Mount Doom awaits us, fellowship of OpenKore!


Top
 Profile  
 
 Post subject: Re: euRO | SVN | Blacksmith repair skill causes disconnect
PostPosted: 26 Sep 2008, 11:59 
Offline
Moderators
Moderators
User avatar

Joined: 04 Apr 2008, 09:30
Posts: 235
Location: My House
i prefer the first idea though....

_________________
Image
Follow The template in Asking Question or Be Trashed


Top
 Profile  
 
 Post subject: Re: euRO | SVN | Blacksmith repair skill causes disconnect
PostPosted: 26 Sep 2008, 17:27 
Offline
Super Moderators
Super Moderators
User avatar

Joined: 06 May 2008, 12:47
Posts: 801
kLabMouse'es suggestions wrote:
1) Repair Auto must be AI Based!
2) use global Array for ItemsRapair, or add custom valuables for those Items.
3) On console Command, try to Read from ItemsReapir or from Items itself thouse Custom varuables, and pass them to Send function.

So thats basically what i did, except for 3, where kore will read from the %repairList in the sendRepairItem sub.
Thanks to kLabMouse, and Bibian for their suggestions.


Oh yea, added a little bonus:
repairAuto_list Knife, Chain Mail

note:
ONLY list the item's basical name, the items can have any number of slots, upgrades, element, vvs, cards but you must only list the basical name !

description:
When repairAuto 1, in the config.
Then kore will only repair the items in repairAuto_list.
Like in the example above, kore will first repair Chain Mail [0], Chain Mail [1] [any Card] and Knife [3], ... you get the idea

[EDIT]
there is a problem when you move away from the blacksmith bot that is casting Weapon Repair,
if you are too far away, the skill will not end and the AI will get stuck on the bs bot's end.
In this case the bs bot does not get the "UseSkill - Done" message, i believe this has something to do with another bug.
Guys, i believe that there is a flaw somewhere because the task UseSkill remains active, even after the skill is casted, and the repair failed ! (because the range is too far)

kore aiv wrote:
ai_seq (auto) =
Active tasks: UseSkill
Inactive tasks: -

_________________
One ST0 to rule them all? One PE viewer to find them!
One ST_kRO to bring them all and in the darkness bind them...

Mount Doom awaits us, fellowship of OpenKore!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group