Openkore.com

OpenKore Forums
It is currently 18 Jun 2019, 23:11

All times are UTC - 5 hours [ DST ]





Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 10 posts ] 
Author Message
 Post subject: Autoupdate.pl error | r6927
PostPosted: 30 Oct 2009, 01:50 
Offline
Noob
Noob
User avatar

Joined: 27 Oct 2009, 01:09
Posts: 15
error when running autoupdate.pl

Code:
$ perl autoupdate.pl
-===================== OpenKore Auto Update tool =====================-
Checking OpenKore core files for updates...
  Fetching updates...
Unable to do svn update\-\-force \-\-accept\ theirs\-conflict .
svn: invalid option: --accept theirs-conflict
Type 'svn help' for usage.
at /home/mohano/games/openkore-2.0.7/src/deps/SVN/Updater.pm line 18
   SVN::Updater::_svn_command('SVN::Updater=HASH(0xa066188)', 'update', '--force', '--accept theirs-conflict') called at /home/mohano/games/openkore-2.0.7/src/deps/SVN/Updater.pm line 90
   SVN::Updater::update('SVN::Updater=HASH(0xa066188)', '--force', '--accept theirs-conflict') called at autoupdate.pl line 41
   autoupdate::upgrade(., 'OpenKore core files') called at autoupdate.pl line 47


Note
Code:
svn update --force --accept thier-conflict


is a valid working command so we can rules out syntax errors/typos :D

script run on
Debian 5.0.3 Lenny
Perl v5.10.0 built for i486-linux-gnu-thread-multi

Thanks 8-)

_________________
My Flickr | Blog
Status: Idle!


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 30 Oct 2009, 06:26 
Offline
OpenKore Monk
OpenKore Monk

Joined: 04 Apr 2008, 10:10
Posts: 474
Could it be your svn version does not have that particular switch enabled?

_________________
Got your topic trashed by a mod?

Trashing topics is one click, and moving a topic to its proper forum is a lot harder. You expend the least effort in deciding where to post, mods expend the least effort by trashing.

Have a nice day.


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 30 Oct 2009, 14:43 
Offline
Noob
Noob
User avatar

Joined: 27 Oct 2009, 01:09
Posts: 15
kali wrote:
Could it be your svn version does not have that particular switch enabled?


nope my svn have that switch tested by running manually it does work even i removed --accept leave --force it still show the same error

_________________
My Flickr | Blog
Status: Idle!


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 30 Oct 2009, 17:39 
Offline
Administrator
Administrator
User avatar

Joined: 24 Apr 2008, 12:02
Posts: 1301
Or I'm Blind. OR "update\-\-force" has no space between?

_________________
Join our Team. Click here.
Image


Image


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 30 Oct 2009, 17:50 
Offline
Administrator
Administrator
User avatar

Joined: 24 Apr 2008, 12:02
Posts: 1301
Fixed in r6929.
Try it out.

_________________
Join our Team. Click here.
Image


Image


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 30 Oct 2009, 19:10 
Offline
Developers
Developers

Joined: 05 Dec 2008, 05:42
Posts: 1811
Code:
# Updates current working directory from the latest repository contents.
sub update {
   my ($self, @params) = @_;
   $self->_svn_command('cleanup'); # Cleaup Repos, if something go wrong
   return $self->_svn_command('update ', @params);
}

# Diffs the file against the repository.
sub diff {
   return join('', shift()->_svn_command('diff', @_));
}

# Checks-out working copy from the REPOSITORY into directory given by 'path' option.
sub checkout {
   my ($self, $repository) = @_;
   mkdir($self->path) or confess "Unable to create " . $self->path;
   return $self->_svn_command('checkout', $repository, '.');
}


How about spaces in diff and checkout? Do they work?


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 31 Oct 2009, 03:02 
Offline
Noob
Noob
User avatar

Joined: 27 Oct 2009, 01:09
Posts: 15
Code:
-===================== OpenKore Auto Update tool =====================-
Checking OpenKore core files for updates...
  Fetching updates...
Unable to do svn update  \-\-force \-\-accept\ theirs\-conflict .
svn: invalid option: --accept theirs-conflict
Type 'svn help' for usage.
at /home/mohano/games/openkore-2.0.7/src/deps/SVN/Updater.pm line 18
   SVN::Updater::_svn_command('SVN::Updater=HASH(0x9d1da50)', 'update ', '--force', '--accept theirs-conflict') called at /home/mohano/games/openkore-2.0.7/src/deps/SVN/Updater.pm line 90
   SVN::Updater::update('SVN::Updater=HASH(0x9d1da50)', '--force', '--accept theirs-conflict') called at autoupdate.pl line 41
   autoupdate::upgrade(., 'OpenKore core files') called at autoupdate.pl line 47


my svn have the option:

Code:
  --accept ARG             : specify automatic conflict resolution action
                            ('postpone', 'base', 'mine-conflict',
                             'theirs-conflict', 'mine-full', 'theirs-full',
                             'edit', 'launch')


seem it does not regconize the option, i manage to fix it by changing how autoupdate send the command instead using:

Code:
$sa->update("--force", "--accept theirs-conflict");


which the script does not regconize the --accept option i change it to:

Code:
$sa->update("--force", "--accept=theirs-conflict");


it work now, seem autoupdate.pl or maybe Updater.pm can parse a SVN option that contain space in it, i tested with other svn option that have space in it like --depth infinity it will end up showing option is in invalid by the autoupdater

Cheers

_________________
My Flickr | Blog
Status: Idle!


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 17 Nov 2009, 10:20 
Offline
Administrator
Administrator
User avatar

Joined: 24 Apr 2008, 12:02
Posts: 1301
Hmm...
gimme output of "svn -v"
to know the version of SVN tool used by you.

_________________
Join our Team. Click here.
Image


Image


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 22 Dec 2009, 17:30 
Offline
Developers
Developers

Joined: 05 Dec 2008, 05:42
Posts: 1811
"--accept theirs-conflict" fixed.


Top
 Profile  
 
 Post subject: Re: Autoupdate.pl error | r6927
PostPosted: 22 Dec 2009, 18:14 
Offline
Administrator
Administrator
User avatar

Joined: 24 Apr 2008, 12:02
Posts: 1301
Closed.

_________________
Join our Team. Click here.
Image


Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 10 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group