Openkore.com
http://forums.openkore.com/

Mystical Amplification problem (I think)
http://forums.openkore.com/viewtopic.php?f=61&t=14293
Page 1 of 2

Author:  punkiey [ 02 Apr 2011, 11:37 ]
Post subject:  Mystical Amplification problem (I think)

Mystical Amplification last for 30 secs and cleared after you cast some attack skill like Fire Bolt, and you have to recast it for it to amp the next damaging skill.

Problem:
-I set the bot to cast fire bolt with the "whenStatusActive Mystical Amplification".
-I set the bot to cast amp when "whenStatusInactive Mystical Amplification".

-But, the bot continue to recast the 2nd fire bolt without casting amp first eventho I put "whenStatusActive Mystical Amplification".

Here is the code:
Quote:
attackSkillSlot Fire Bolt {
lvl 10
sp > 30
whenStatusInactive EFST_POSTDELAY
whenStatusActive Mystical Amplification
monsters Holden
}

useSelf_skill Mystical Amplification {
lvl 10
sp > 50
whenStatusInactive Mystical Amplification, EFST_POSTDELAY
}


Suggestion?

-puNKiey

Author:  EternalHarvest [ 14 Apr 2011, 15:29 ]
Post subject:  Re: Mystical Amplification problem (I think)

Casting of the second bolt starts before status disappears?

Author:  punkiey [ 17 Apr 2011, 09:31 ]
Post subject:  Re: Mystical Amplification problem (I think)

Unfortunately, the amp status should be removed after the cast of first bolt. But it still there. Eventho the amp status is still on, and you cast the second bolt, the second bolt will not be amped.

The amp status should expired after the first bolt, and recast it, for it to amp the second bolt.

To do:
Mystical Amplification
- Expired in 30 secs = done
- Expired after damaging skill casted = not yet done

I wish I can update the code myself. But I dont know where the code might be. Suggestion?

Or perhaps, I got everyhing wrong? yikes! :?

-puNKiey

Author:  EternalHarvest [ 17 Apr 2011, 17:48 ]
Post subject:  Re: Mystical Amplification problem (I think)

So that status just never disappears in Kore?

Author:  punkiey [ 20 Apr 2011, 14:11 ]
Post subject:  Re: Mystical Amplification problem (I think)

It do disappear after 30secs. But when you cast amp, and cast damaging skill, it remain until the 30secs timeout reached. It should be cleared after damaging skill casted, so that "whenStatusActive Mystical Amplification" can be use properly.

-puNKiey

Author:  Jackyhk [ 21 Apr 2011, 05:08 ]
Post subject:  Re: Mystical Amplification problem (I think)

Why don't you try to remove EFST_POSTDELAY from the Fire Bolt and see if it helps, or try to remove "monsters Holden".

If you tried everything else, how about trying AttackComboSlot? (although it might not work since MA is not really an attack skill...)

Something like

attackComboSlot Fire Bolt {
lvl 10
sp > 30
afterSkill Mystical Amplification
waitBeforeUse <--- this you have to find out the skill delay after Mystical Amp
}

I never botted a mage, so I don't know if they work. :s

Author:  EternalHarvest [ 21 Apr 2011, 09:13 ]
Post subject:  Re: Mystical Amplification problem (I think)

Yea, it probably can be configured like that too (Amplification needs to be configured as attackSkillSlot with isSelfSkill in this case).

Author:  Boq [ 22 May 2011, 12:42 ]
Post subject:  Re: Mystical Amplification problem (I think)

I have had this issue as well, and cannot seem to figure out a solution. Openkore seems to fail to cancel the presence of Mystical Amplification after casting a spell which consumes the effect.

I tried something as suggested in this thread, using the combos, but it doesn't seem to work as intended. MA is still not cast when it should be. Might someone give any pointers? What I had tried was:

attackSkillSlot Mystical Amplification {
lvl 5
dist
maxCastTime 0
minCastTime 0
hp
sp
onAction
whenStatusActive
whenStatusInactive
whenFollowing
spirit
aggressives
previousDamage
stopWhenHit 0
inLockOnly 0
notInTown 0
timeout 0
disabled 0
monsters
notMonsters
maxAttempts 0
maxUses 0
target_whenStatusActive
target_whenStatusInactive
target_deltaHp
inInventory
isSelfSkill 1
manualAI 0
}


attackComboSlot Cold Bolt{
lvl 5
dist 9
monsters Flora, Beetle King, Savage
afterSkill Mystical Amplification
waitBeforeUse 1
maxUses 1
maxAttempts 1
target_deltaHp = 0
isSelfSkill 0
disabled 0
}


Thanks for anyone's input.

Author:  EternalHarvest [ 06 Oct 2011, 15:37 ]
Post subject:  Re: Mystical Amplification problem (I think)

eAthena doesn't seem to have this bug.

This plugin should solve it: http://openkore.svn.sourceforge.net/vie ... iew=markup

Author:  Kaspy [ 27 Jul 2012, 19:43 ]
Post subject:  BUG in the skill Amplify Magic Power (ID# 366)

Image

[EN] (Translated by Triper)
Amplify Magic Power boosts the magical attack only for the first skill used after it as seen in here:
http://ratemyserver.net/index.php?sk_na ... rch=Search
The problem is that OpenKore keeps saying that is still on, even after using any skill.

I would like to know if this is a bug that only applies to bRO. If not, I can fix it.
Any tip, you're welcome to talk about it, I appreciate ^^
And while on this... Would it be good and possible to show how much time is left to any buff end or there is already something that does that?

[PT-BR]
A skill Amplificação Mística aumenta o ataque mágica apenas na primeira habilidade após ela ser usada, conforme pode ser visto aqui:
http://ratemyserver.net/index.php?sk_na ... rch=Search
O problema é que o OpenKore continua dizendo que ela esta ativada, mesmo após usar alguma habilidade.

Gostaria de saber se esse BUG é apenas no bRO. Se não for, posso corrigir.
Qual quer dica, pode falar, agradeço ^^
Aproveitando o tópico... Será que seria viável e possível mostrar quando tempo falta para determinado buff acabar? Ou já tem isso?

Page 1 of 2 All times are UTC - 5 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/