Openkore.com

OpenKore Forums
It is currently 22 Oct 2018, 05:35

All times are UTC - 5 hours [ DST ]





Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 13 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: bot slave doesnt work
PostPosted: 01 May 2010, 19:57 
Offline
Noob
Noob

Joined: 01 May 2010, 19:36
Posts: 5
Hi everyone, i'm novice with using botting kore.
using version 2.0.7, i got a pb with my slave.
explications :
i'm using the bot to slave my main character. So the bot is in party, follow me and has to support all the support skills which possess and of course, always hold me on with life and no status ailment.
i tried lot of programation of partyskill, but i cant do anymore , i havent any idee what is wrong on my partyskill.
i'm listing it below

partySkill Blessing {
lvl 10
#maxCastTime 0
#minCastTime 0
#hp
sp > 64
#homunculus_hp
#homunculus_sp
#homunculus_dead
#onAction
#whenStatusActive
#whenStatusInactive Blessing
#whenFollowing
#spirit
#aggressives
#monsters
#notMonsters
#stopWhenHit 1
#inLockOnly 1
#notWhileSitting 1
notInTown 1
#timeout 0
#disabled 0
#manualAI 0
#target
#target_hp
#target_isJob
#target_isNotJob
target_whenStatusActive Cursed
target_whenStatusInactive Blessing
#target_aggressives
#target_monsters
#target_timeout 0
#target_deltaHp
#target_dead 1
#inInventory
#isSelfSkill 1
}

partySkill Increase AGI {
lvl 10
#maxCastTime 0
#minCastTime 0
#hp
sp > 45
#homunculus_hp
#homunculus_sp
#homunculus_dead
#onAction
#whenStatusActive
#whenStatusInactive Increase AGI
#whenFollowing
#spirit
#aggressives
#monsters
#notMonsters
#stopWhenHit 1
#inLockOnly 1
#notWhileSitting 1
notInTown 1
#timeout 0
#disabled 0
#manualAI 0
#target
#target_hp
#target_isJob
#target_isNotJob
target_whenStatusActive Decrease AGI
target_whenStatusInactive Increase AGI
#target_aggressives
#target_monsters
#target_timeout 0
#target_deltaHp
#target_dead 1
#inInventory
#isSelfSkill 1
}

partySkill Cure {
lvl 1
#maxCastTime 0
#minCastTime 0
#hp
sp > 25
#homunculus_hp
#homunculus_sp
#homunculus_dead
#onAction
#whenStatusActive Blinded, Silenced
#whenStatusInactive
#whenFollowing 1
#spirit
#aggressives
#monsters
#notMonsters
#stopWhenHit 1
#inLockOnly 1
#notWhileSitting 1
notInTown 1
#timeout 0
#disabled 0
#inInventory
#manualAI 0
target_whenStatusActive Blinded, Silenced
#target_whenStatusInactive

}

partySkill Status Recovery {
lvl 1
#maxCastTime 0
#minCastTime 0
#hp
sp > 25
#homunculus_hp
#homunculus_sp
#homunculus_dead
#onAction
#whenStatusActive
#whenStatusInactive
#whenFollowing 1
#spirit
#aggressives
#monsters
#notMonsters
#stopWhenHit 1
#inLockOnly 1
#notWhileSitting 1
notInTown 1
#timeout 0
#disabled 0
#inInventory
#manualAI 0
target_whenStatusActive Frozen, Stunned, Petrified, Petrifying
#target_whenStatusInactive

}
with this programing, the bot doesnt buff me but help me with status ailment. when i desactivate the 'target_whenstatusactive' and i activate the 'whenstatusinactive', the bot for sure buff me, but doesnt help me with statusailment anymore.

To be exact, i havent the formula for my bot slave , to buff me AND help me with status ailment.
The ones which have success that in game, i'd like for their help.

Sorry for my bad english, i'm from europe but dont have a use of english.

Thx to everyone.

In reply waiting ;)


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 01 May 2010, 21:59 
Offline
Perl Monk
Perl Monk
User avatar

Joined: 04 Apr 2008, 14:04
Posts: 428
Location: Brazil
The block will only be used only if all the conditions are met. So for example, on the blessing block, it will only activate when target is not with blessing status and when it is cursed.
You can use multiple blocks with the same skill if you want separate conditions.

_________________
Quit.


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 02 May 2010, 05:32 
Offline
Noob
Noob

Joined: 01 May 2010, 19:36
Posts: 5
Hi Mushroom and thx for replying :)

Mushroom wrote:
The block will only be used only if all the conditions are met. So for example, on the blessing block, it will only activate when target is not with blessing status and when it is cursed.

Yes, i know that, but unfortunately, if i activate 'whenStatusInactive' in same time with 'target_whenStatusActive / target_whenStatusInactive' , the bot doesnt do anything :(
Mushroom wrote:
You can use multiple blocks with the same skill if you want separate conditions.

i really not understood at all this sentence when you're meaning multiple blocks and separate conditions.
Can you write me what is wrong with my block (the blessing block for example)

Thx to you


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 02 May 2010, 13:02 
Offline
Human
Human

Joined: 04 Apr 2008, 22:55
Posts: 26
#target??

Quote:
target "Master's Name" without " "


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 03 May 2010, 09:22 
Offline
Noob
Noob
User avatar

Joined: 27 Nov 2008, 18:47
Posts: 7
Quote:
partySkill Blessing {
lvl 10
#hp
sp > 5% <-- change to % for easy viewing
notInTown 1
#target <-- delete the # and put the master's name here
target_whenStatusActive Cursed
target_whenStatusInactive <---blank
}


First of all, pls do not use the # inside the block. It is very confusing. Just delete whatever you dont want inside the block.

If u are using target conditions, u must specify the target name.

It is best to use buff and dispel status in different block. Dont lump them together if you are new to bots.

The above block will cancel the cursed status of your bot.


Quote:
partySkill Blessing {
lvl 10
hp
sp > 5%
onAction
whenFollowing
stopWhenHit 0
inLockOnly 0
notWhileSitting 0
notInTown 1
timeout
disabled 0
manualAI 0
target <--master's name here
target_whenStatusActive
target_whenStatusInactive Blessing
target_timeout
isSelfSkill 0
}


The above block will use Blessing on your bot .

_________________
The Bot Guru


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 03 May 2010, 09:30 
Offline
Developers
Developers

Joined: 05 Dec 2008, 05:42
Posts: 1811
Tonberry wrote:
First of all, pls do not use the # inside the block. It is very confusing. Just delete whatever you dont want inside the block.

Commenting will have the same effect as deleting, inside block or outside. What is confusing?


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 03 May 2010, 09:53 
Offline
Noob
Noob
User avatar

Joined: 27 Nov 2008, 18:47
Posts: 7
EternalHarvest wrote:
Tonberry wrote:
First of all, pls do not use the # inside the block. It is very confusing. Just delete whatever you dont want inside the block.

Commenting will have the same effect as deleting, inside block or outside. What is confusing?

Bcos you need to identify which is for buff and which is for status dispelling. Keeping it tidy will do you good in long term especially in priest config.

_________________
The Bot Guru


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 03 May 2010, 15:20 
Offline
Noob
Noob

Joined: 01 May 2010, 19:36
Posts: 5
Thx guys for replying :)

@tonberry
Thank you for your help, it's very appreciate.
(thx for the hint "target")
i saw what you want to demonstrate as to know how got a bot with blessing my main character for a part and another part you show me how to cancel the cursed status. But these manipulations, i success them in differents ways.

partySkill Blessing {
lvl 10
sp > 5%
notInTown 1
target_whenStatusActive Cursed
target_whenStatusInactive Blessing
}
with this block (above), the bot cures me from cursed effect, but dont bless me on sight of the bot
---
partySkill Blessing {
lvl 10
sp > 5%
notInTown 1
whenStatusInactive Blessing
}
with this block (above), the bot bless itself and bless me on sight but doesnt cure me from cursed effect.
---
to understand what i'd like to have is a blessing block where the bot can do the combination of the two blocks, that's to say, the bot have to bless me on sight when i lost the blessing effect, and of course when i'm under attack with monster which cursed me, i'd like the bot can cure me the cursed effect of course :)

all is said guys, that's why i'm looking for help of expert programming, because i cant do, or see, what is wrong in the programation of partyskill blessing.
By the way, i realy dont know if it's possible or not. Maybe the thing i asked is impossible to do...i dont know at all, thats why i ask for your help

Thanks to everyone for helping me with this subjet ;)


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 11 May 2010, 12:38 
Offline
Noob
Noob

Joined: 01 May 2010, 19:36
Posts: 5
hi :)

i havent replies since 2 weeks.

i'd like to Bring Up My Post.
Cause i'm asking for help with good practicians of bot to tell me if what i'm asking is possible or impossible to do.

In waiting for replies

see you soon


Top
 Profile  
 
 Post subject: Re: bot slave doesnt work
PostPosted: 13 May 2010, 22:56 
Offline
Perl Monk
Perl Monk
User avatar

Joined: 04 Apr 2008, 14:04
Posts: 428
Location: Brazil
I think you didn't understand the block right.
Code:
partySkill Blessing {
lvl 10
sp > 5%
notInTown 1
target_whenStatusActive Cursed
target_whenStatusInactive Blessing
}

Here, Openkore will only use Blessing if the TARGET is in Cursed status it's NOT with Blessing buff.

Code:
partySkill Blessing {
lvl 10
sp > 5%
notInTown 1
whenStatusInactive Blessing
}

Here, the bot will only use Blessing in your TARGET if YOU are not in Blessing effect.

_________________
Quit.


Top
 Profile  
 
Display posts from previous:  Sort by  
Forum locked This topic is locked, you cannot edit posts or make further replies.  [ 13 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group